re = /(?i)(?:http:\/\/)?(?:w+\.)?\K\w+(?=\.[a-z]{2,4})/m
str = 'www.facebook.com http://www.facebook.com http://facebook.com '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result