using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\"".+\""$(,|\))|\$[a-zA-Z_][a-zA-Z0-9_]{0,31}[\[\""a-zA-Z0_9\""\]]*";
string input = @"(""dasdas"",$dasdd,""dadsad"")
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}