re = /\".+\"$(,|\))|\$[a-zA-Z_][a-zA-Z0-9_]{0,31}[\[\"a-zA-Z0_9\"\]]*/m
str = '("dasdas",$dasdd,"dadsad")
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end