$re = '/\".+\"$(,|\))|\$[a-zA-Z_][a-zA-Z0-9_]{0,31}[\[\"a-zA-Z0_9\"\]]*/m';
$str = '("dasdas",$dasdd,"dadsad")
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);