import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\".+\\\"$(,|\\))|\\$[a-zA-Z_][a-zA-Z0-9_]{0,31}[\\[\\\"a-zA-Z0_9\\\"\\]]*";
final String string = "(\"dasdas\",$dasdd,\"dadsad\")\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}