#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<tr>(?:.(?!<tr>))*?<td>.*?</td>(?:.(?!<tr>))*?<td>(.*?)</td>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="utf-8">" & @CRLF & _
" <style>" & @CRLF & _
" " & @CRLF & _
" table, th, td {" & @CRLF & _
" border: 1px solid black;" & @CRLF & _
" border-collapse: collapse;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" table{" & @CRLF & _
" width: 75%;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" text-align: center;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" td{" & @CRLF & _
" padding: 5px;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" #actualTime{" & @CRLF & _
" background-color: green" & @CRLF & _
" }" & @CRLF & _
" </style>" & @CRLF & _
"" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<header>" & @CRLF & _
"" & @CRLF & _
"</header>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
"" & @CRLF & _
" <table>" & @CRLF & _
" <tr id="actualTime">" & @CRLF & _
"" & @CRLF & _
" <th>actualTime</th>" & @CRLF & _
" <th>cancelled</th>" & @CRLF & _
" <th>commercialTrack</th>" & @CRLF & _
" <th>countryCode</th>" & @CRLF & _
" <th>scheduledTime</th>" & @CRLF & _
" <th>stationShortCode</th>" & @CRLF & _
" <th>stationUICCode</th>" & @CRLF & _
" <th>trainStopping</th>" & @CRLF & _
" <th>type</th>" & @CRLF & _
" <th>trainNumber</th> " & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
" <tr class="type">" & @CRLF & _
" " & @CRLF & _
" <td>" & @CRLF & _
" 2019-08-06T04:48:00.000Z" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" False" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" FI" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" 2019-08-06T04:48:00.000Z" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" JVS " & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" 1272" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" False" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" <td>" & @CRLF & _
" DEPARTURE" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" <td>" & @CRLF & _
" 150" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="countryCode">" & @CRLF & _
" <td>" & @CRLF & _
" 2019-08-06T06:04:39.000Z" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" False" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
"" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" FI" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" 2019-08-06T06:04:39.000Z" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" R702" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" 98998" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" False" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" <td>" & @CRLF & _
" ARRIVAL" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" <td>" & @CRLF & _
" 150" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" 2019-08-06T07:03:12.000Z" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" False" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" FI" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" 2019-08-06T07:03:12.000Z" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" ILA" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" 98998" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" 9" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" <td>" & @CRLF & _
" ARRIVAL" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" <td>" & @CRLF & _
" 8337" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </table>" & @CRLF & _
"" & @CRLF & _
"</body>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<footer>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</footer>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")