use strict;
my $str = '<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<style>
table, th, td {
border: 1px solid black;
border-collapse: collapse;
}
table{
width: 75%;
margin-left: auto;
margin-right: auto;
text-align: center;
}
td{
padding: 5px;
}
#actualTime{
background-color: green
}
</style>
</head>
<header>
</header>
<body>
<table>
<tr id="actualTime">
<th>actualTime</th>
<th>cancelled</th>
<th>commercialTrack</th>
<th>countryCode</th>
<th>scheduledTime</th>
<th>stationShortCode</th>
<th>stationUICCode</th>
<th>trainStopping</th>
<th>type</th>
<th>trainNumber</th>
</tr>
<tr class="type">
<td>
2019-08-06T04:48:00.000Z
</td>
<td>
False
</td>
<td>
</td>
<td>
FI
</td>
<td>
2019-08-06T04:48:00.000Z
</td>
<td>
JVS
</td>
<td>
1272
</td>
<td>
False
</td>
<td>
DEPARTURE
</td>
<td>
150
</td>
</tr>
<tr class="countryCode">
<td>
2019-08-06T06:04:39.000Z
</td>
<td>
False
</td>
<td>
</td>
<td>
FI
</td>
<td>
2019-08-06T06:04:39.000Z
</td>
<td>
R702
</td>
<td>
98998
</td>
<td>
False
</td>
<td>
ARRIVAL
</td>
<td>
150
</td>
</tr>
<tr>
<td>
2019-08-06T07:03:12.000Z
</td>
<td>
False
</td>
<td>
</td>
<td>
FI
</td>
<td>
2019-08-06T07:03:12.000Z
</td>
<td>
ILA
</td>
<td>
98998
</td>
<td>
9
</td>
<td>
ARRIVAL
</td>
<td>
8337
</td>
</tr>
</table>
</body>
<footer>
</footer>
</html>';
my $regex = qr/<tr>(?:.(?!<tr>))*?<td>.*?</td>(?:.(?!<tr>))*?<td>(.*?)</td>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}