using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tr>(?:.(?!<tr>))*?<td>.*?</td>(?:.(?!<tr>))*?<td>(.*?)</td>";
string input = @"<!DOCTYPE html>
<html>
<head>
<meta charset=""utf-8"">
<style>
table, th, td {
border: 1px solid black;
border-collapse: collapse;
}
table{
width: 75%;
margin-left: auto;
margin-right: auto;
text-align: center;
}
td{
padding: 5px;
}
#actualTime{
background-color: green
}
</style>
</head>
<header>
</header>
<body>
<table>
<tr id=""actualTime"">
<th>actualTime</th>
<th>cancelled</th>
<th>commercialTrack</th>
<th>countryCode</th>
<th>scheduledTime</th>
<th>stationShortCode</th>
<th>stationUICCode</th>
<th>trainStopping</th>
<th>type</th>
<th>trainNumber</th>
</tr>
<tr class=""type"">
<td>
2019-08-06T04:48:00.000Z
</td>
<td>
False
</td>
<td>
</td>
<td>
FI
</td>
<td>
2019-08-06T04:48:00.000Z
</td>
<td>
JVS
</td>
<td>
1272
</td>
<td>
False
</td>
<td>
DEPARTURE
</td>
<td>
150
</td>
</tr>
<tr class=""countryCode"">
<td>
2019-08-06T06:04:39.000Z
</td>
<td>
False
</td>
<td>
</td>
<td>
FI
</td>
<td>
2019-08-06T06:04:39.000Z
</td>
<td>
R702
</td>
<td>
98998
</td>
<td>
False
</td>
<td>
ARRIVAL
</td>
<td>
150
</td>
</tr>
<tr>
<td>
2019-08-06T07:03:12.000Z
</td>
<td>
False
</td>
<td>
</td>
<td>
FI
</td>
<td>
2019-08-06T07:03:12.000Z
</td>
<td>
ILA
</td>
<td>
98998
</td>
<td>
9
</td>
<td>
ARRIVAL
</td>
<td>
8337
</td>
</tr>
</table>
</body>
<footer>
</footer>
</html>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}