# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<tr>(?:.(?!<tr>))*?<td>.*?</td>(?:.(?!<tr>))*?<td>(.*?)</td>"
test_str = ("<!DOCTYPE html>\n\n"
"<html>\n"
"<head>\n"
" <meta charset=\"utf-8\">\n"
" <style>\n"
" \n"
" table, th, td {\n"
" border: 1px solid black;\n"
" border-collapse: collapse;\n"
" }\n\n"
" table{\n"
" width: 75%;\n"
" margin-left: auto;\n"
" margin-right: auto;\n"
" text-align: center;\n"
" }\n\n"
" td{\n"
" padding: 5px;\n"
" }\n\n"
" #actualTime{\n"
" background-color: green\n"
" }\n"
" </style>\n\n"
"</head>\n\n\n"
"<header>\n\n"
"</header>\n\n\n"
"<body>\n\n"
" <table>\n"
" <tr id=\"actualTime\">\n\n"
" <th>actualTime</th>\n"
" <th>cancelled</th>\n"
" <th>commercialTrack</th>\n"
" <th>countryCode</th>\n"
" <th>scheduledTime</th>\n"
" <th>stationShortCode</th>\n"
" <th>stationUICCode</th>\n"
" <th>trainStopping</th>\n"
" <th>type</th>\n"
" <th>trainNumber</th> \n"
" </tr>\n\n"
" <tr class=\"type\">\n"
" \n"
" <td>\n"
" 2019-08-06T04:48:00.000Z\n"
" </td>\n"
" <td>\n"
" False\n"
" </td>\n"
" <td>\n"
" \n"
" </td>\n"
" <td>\n"
" FI\n"
" </td>\n"
" <td>\n"
" 2019-08-06T04:48:00.000Z\n"
" </td>\n"
" <td>\n"
" JVS \n"
" </td>\n"
" <td>\n"
" 1272\n"
" </td>\n"
" <td>\n"
" False\n"
" </td>\n\n"
" <td>\n"
" DEPARTURE\n"
" </td>\n\n"
" <td>\n"
" 150\n"
" </td>\n\n"
" </tr>\n"
" <tr class=\"countryCode\">\n"
" <td>\n"
" 2019-08-06T06:04:39.000Z\n"
" </td>\n"
" <td>\n"
" False\n"
" </td>\n"
" <td>\n\n"
" </td>\n"
" <td>\n"
" FI\n"
" </td>\n"
" <td>\n"
" 2019-08-06T06:04:39.000Z\n"
" </td>\n"
" <td>\n"
" R702\n"
" </td>\n"
" <td>\n"
" 98998\n"
" </td>\n"
" <td>\n"
" False\n"
" </td>\n\n"
" <td>\n"
" ARRIVAL\n"
" </td>\n\n"
" <td>\n"
" 150\n"
" </td>\n"
" </tr>\n\n\n"
" <tr>\n"
" <td>\n"
" 2019-08-06T07:03:12.000Z\n"
" </td>\n"
" <td>\n"
" False\n"
" </td>\n"
" <td>\n"
" \n"
" </td>\n"
" <td>\n"
" FI\n"
" </td>\n"
" <td>\n"
" 2019-08-06T07:03:12.000Z\n"
" </td>\n"
" <td>\n"
" ILA\n"
" </td>\n"
" <td>\n"
" 98998\n"
" </td>\n"
" <td>\n"
" 9\n"
" </td>\n\n"
" <td>\n"
" ARRIVAL\n"
" </td>\n\n"
" <td>\n"
" 8337\n"
" </td>\n"
" </tr>\n\n\n"
" </table>\n\n"
"</body>\n\n\n"
"<footer>\n\n\n"
"</footer>\n"
"</html>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.