using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,\[\]]+(?=(?:\[|,))";
string input = @"DOG,THIS[3.8418],DOPE[4.7699],REACXH[3.2852000000000006],RACKET[0.8865999999999999],0321859[2.898411]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}