re = /[^,\[\]]+(?=(?:\[|,))/
str = 'DOG,THIS[3.8418],DOPE[4.7699],REACXH[3.2852000000000006],RACKET[0.8865999999999999],0321859[2.898411]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end