import re
regex = re.compile(r"[^,\[\]]+(?=(?:\[|,))")
test_str = "DOG,THIS[3.8418],DOPE[4.7699],REACXH[3.2852000000000006],RACKET[0.8865999999999999],0321859[2.898411]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")