import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^,\\[\\]]+(?=(?:\\[|,))";
final String string = "DOG,THIS[3.8418],DOPE[4.7699],REACXH[3.2852000000000006],RACKET[0.8865999999999999],0321859[2.898411]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}