using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Lord |Lady |Ser )?(Agatha|John)?(Cain)?";
string input = @"Lord John Cain asked...
Ser John has...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating.
He looked at them. Cain was walking...
The castle of Cain is...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}