package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Lord |Lady |Ser )?(Agatha|John)?(Cain)?`)
var str = `Lord John Cain asked...
Ser John has...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating.
He looked at them. Cain was walking...
The castle of Cain is...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}