const regex = /(Lord |Lady |Ser )?(Agatha|John)?(Cain)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Lord |Lady |Ser )?(Agatha|John)?(Cain)?', 'g')
const str = `Lord John Cain asked...
Ser John has...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating.
He looked at them. Cain was walking...
The castle of Cain is...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}