$re = '/(Lord |Lady |Ser )?(Agatha|John)?(Cain)?/';
$str = 'Lord John Cain asked...
Ser John has...
Inside the castle, Lord Cain was speaking with Lady Cain.
John was eating.
He looked at them. Cain was walking...
The castle of Cain is...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);