const regex = /^[^\s]+\s[^\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s]+\\s[^\\s]+', 'gm')
const str = `First example from this part 10 t/m 16 it has to be removed
Second example from this part 12 t/m 22 it has to be removed`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}