$re = '/^[^\s]+\s[^\s]+/m';
$str = 'First example from this part 10 t/m 16 it has to be removed
Second example from this part 12 t/m 22 it has to be removed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);