re = /^[^\s]+\s[^\s]+/m
str = 'First example from this part 10 t/m 16 it has to be removed
Second example from this part 12 t/m 22 it has to be removed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end