using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)(?:\s?\[[^\]]+\])(.+)?";
string input = @"File Name [24.9MB].ext
Folder Name [1GB]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}