$re = '/(.+)(?:\s?\[[^\]]+\])(.+)?/';
$str = 'File Name [24.9MB].ext
Folder Name [1GB]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);