package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+)(?:\s?\[[^\]]+\])(.+)?`)
var str = `File Name [24.9MB].ext
Folder Name [1GB]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}