re = /(.+)(?:\s?\[[^\]]+\])(.+)?/
str = 'File Name [24.9MB].ext
Folder Name [1GB]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end