#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""\s*function\(.*\)(?:[^"\\]|\\")*"
Local $sString = "{" & @CRLF & _
" "kay": "function() { " & @CRLF & _
" return 'hello fun" & @CRLF & _
" ction stuff'; }"," & @CRLF & _
" "key": "function() { return 'hello function stuff'; }"," & @CRLF & _
" "koy": "function() { return " & @CRLF & _
" \"hello function stuff\"; }"" & @CRLF & _
" "function(lll) { return 'hello" & @CRLF & _
"gfgf" & @CRLF & _
"jgjg" & @CRLF & _
"hfghg" & @CRLF & _
"function stuff'; }""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")