$re = '/"\s*function\(.*\)(?:[^"\\\\]|\\\\")*/';
$str = '{
"kay": "function() {
return \'hello fun
ction stuff\'; }",
"key": "function() { return \'hello function stuff\'; }",
"koy": "function() { return
\\"hello function stuff\\"; }"
"function(lll) { return \'hello
gfgf
jgjg
hfghg
function stuff\'; }"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);