// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""\s*function\(.*\)(?:[^"\\]|\\")*"#).unwrap();
let string = "{
\"kay\": \"function() {
return 'hello fun
ction stuff'; }\",
\"key\": \"function() { return 'hello function stuff'; }\",
\"koy\": \"function() { return
\\\"hello function stuff\\\"; }\"
\"function(lll) { return 'hello
gfgf
jgjg
hfghg
function stuff'; }\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}