re = /"\s*function\(.*\)(?:[^"\\]|\\")*/
str = '{
"kay": "function() {
return \'hello fun
ction stuff\'; }",
"key": "function() { return \'hello function stuff\'; }",
"koy": "function() { return
\\"hello function stuff\\"; }"
"function(lll) { return \'hello
gfgf
jgjg
hfghg
function stuff\'; }"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end