using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""\s*function\(.*\)(?:\\""|[^""])*""";
string input = @"{
""kay"": ""function() {
return 'hello \n fun
ction stuff'; }"",
""key"": ""function() { return 'hello function stuff'; }"",
""koy"": ""function() { return
\""hello function stuff\""; }""
""function(lll) { return 'hello
gfgf
jgjg
hfghg
function stuff'; }""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}