import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\\s*function\\(.*\\)(?:\\\\\"|[^\"])*\"";
final String string = "{\n"
+ " \"kay\": \"function() { \n"
+ " return 'hello \\n fun\n"
+ " ction stuff'; }\",\n"
+ " \"key\": \"function() { return 'hello function stuff'; }\",\n"
+ " \"koy\": \"function() { return \n"
+ " \\\"hello function stuff\\\"; }\"\n"
+ " \"function(lll) { return 'hello\n"
+ "gfgf\n"
+ "jgjg\n"
+ "hfghg\n"
+ "function stuff'; }\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}