package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"\s*function\(.*\)(?:\\"|[^"])*"`)
var str = `{
"kay": "function() {
return 'hello \n fun
ction stuff'; }",
"key": "function() { return 'hello function stuff'; }",
"koy": "function() { return
\"hello function stuff\"; }"
"function(lll) { return 'hello
gfgf
jgjg
hfghg
function stuff'; }"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}