#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?=.*[A-Z]{1,})(?=.*\d{1,})(?=.*[^A-Za-z0-9]{1,})(?=.*[a-z]{1,})){8,}"
Local $sString = "a" & @CRLF & _
"aaa" & @CRLF & _
"aaaaaaaa" & @CRLF & _
"zaq1@WSX" & @CRLF & _
"ZAQ!2wsx" & @CRLF & _
"11111111" & @CRLF & _
"========" & @CRLF & _
"@@@@@@@@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")