import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=.*[A-Z]{1,})(?=.*\\d{1,})(?=.*[^A-Za-z0-9]{1,})(?=.*[a-z]{1,})){8,}";
final String string = "a\n"
+ "aaa\n"
+ "aaaaaaaa\n"
+ "zaq1@WSX\n"
+ "ZAQ!2wsx\n"
+ "11111111\n"
+ "========\n"
+ "@@@@@@@@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}