$re = '/((?=.*[A-Z]{1,})(?=.*\d{1,})(?=.*[^A-Za-z0-9]{1,})(?=.*[a-z]{1,})){8,}/m';
$str = 'a
aaa
aaaaaaaa
zaq1@WSX
ZAQ!2wsx
11111111
========
@@@@@@@@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);