# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(http(s)?:\/\/)?(([a-zA-Z])([-\w]+\.)+([^\s\.]+[^\s]*)+[^,.\s])$/<a href="http$2:\/\/$3">$0<\/a>/gm;t' <<< "source.com
https://source.com
http://source.com"