package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http(s)?://)?(([a-zA-Z])([-\w]+\.)+([^\s\.]+[^\s]*)+[^,.\s])$`)
var str = `source.com
https://source.com
http://source.com`
var substitution = "<a href="http$2://$3">$0</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}