use strict;
my $str = 'source.com
https://source.com
http://source.com';
my $regex = qr@^(http(s)?://)?(([a-zA-Z])([-\w]+\.)+([^\s\.]+[^\s]*)+[^,.\s])$@mp;
my $subst = '<a href="http$2://$3">$0</a>';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";