re = /^(http(s)?:\/\/)?(([a-zA-Z])([-\w]+\.)+([^\s\.]+[^\s]*)+[^,.\s])$/m
str = 'source.com
https://source.com
http://source.com'
subst = '<a href="http$2://$3">$0</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result