package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([1-9]|[1-5][0-9]|6[0-3])-([1-5][0-9]|6[0-4]|[2-9])`)
var str = `32-1
32-2
1-2
63-10
32-64`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}