re = /([1-9]|[1-5][0-9]|6[0-3])-([1-5][0-9]|6[0-4]|[2-9])/m
str = '32-1
32-2
1-2
63-10
32-64'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end