$re = '/([1-9]|[1-5][0-9]|6[0-3])-([1-5][0-9]|6[0-4]|[2-9])/m';
$str = '32-1
32-2
1-2
63-10
32-64';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);