re = /\/(\w+(?:[^\w\n]+\w+)+[^\w\n]*$)?/m
str = 'CENTRAL CARE HOSPITAL/HOPITAL CENTRALE DE SOINS
ELEMENTARY/INSTITUTION
FOUNDATION INSTITUTION/FUNDATION DEL INSTITUTO
HAPPY SPRING BREAK 20/20'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result