using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\S*[^\S\n]\S*[^\S\n]|\s)(?:\s?[A-Za-z0-9]){5,7}$";
string input = @"A B144BA
A B144BA
AB 144BA
AB1 44BA
AB14 4BA
AB144 BA
AB144B A
AB1 4 4BA
ABCDE
ABCDE
ABCDE
ABC DE
ABCDEFGH";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}