$re = '/^(?!\S*[^\S\n]\S*[^\S\n]|\s)(?:\s?[A-Za-z0-9]){5,7}$/m';
$str = 'A B144BA
A B144BA
AB 144BA
AB1 44BA
AB14 4BA
AB144 BA
AB144B A
AB1 4 4BA
ABCDE
ABCDE
ABCDE
ABC DE
ABCDEFGH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);