import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\S*[^\\S\\n]\\S*[^\\S\\n]|\\s)(?:\\s?[A-Za-z0-9]){5,7}$";
final String string = "A B144BA\n"
+ "A B144BA\n"
+ "AB 144BA\n"
+ "AB1 44BA\n"
+ "AB14 4BA\n"
+ "AB144 BA\n"
+ "AB144B A\n"
+ "AB1 4 4BA\n"
+ " ABCDE\n"
+ "ABCDE\n"
+ "ABCDE \n"
+ "ABC DE\n"
+ "ABCDEFGH";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}