const regex = /^(?!\S*[^\S\n]\S*[^\S\n]|\s)(?:\s?[A-Za-z0-9]){5,7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\S*[^\\S\\n]\\S*[^\\S\\n]|\\s)(?:\\s?[A-Za-z0-9]){5,7}$', 'gm')
const str = `A B144BA
A B144BA
AB 144BA
AB1 44BA
AB14 4BA
AB144 BA
AB144B A
AB1 4 4BA
ABCDE
ABCDE
ABCDE
ABC DE
ABCDEFGH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}