import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-z.0-9]{1,50}@(gmail|outlook|hotmail|zoho|yahoo|)\\.com$";
final String string = "sahilxresta98@gmail.com\n"
+ "literarl@outlook.com\n"
+ "sneha@yahoo.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}