use strict;
my $str = 'sahilxresta98@gmail.com
literarl@outlook.com
sneha@yahoo.com';
my $regex = qr/^[a-zA-z.0-9]{1,50}@(gmail|outlook|hotmail|zoho|yahoo|)\.com$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}