// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-z.0-9]{1,50}@(gmail|outlook|hotmail|zoho|yahoo|)\.com$").unwrap();
let string = "sahilxresta98@gmail.com
literarl@outlook.com
sneha@yahoo.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}