use strict;
my $str = '</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> Tên công ty: {company_name}
</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> (#)Địa chỉ: {company_address}</span></p>
<p style="text-align: justify;"> (#)<span style="font-size: 14px;">{company_branch}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_email}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_phone1}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> </span> (#)<span style="font-size: 14px;">{company_website}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;"> {company_tax_code}</span></p>
<p style="text-align: justify;"><span style="font-size: 14px;">';
my $regex = qr/<p(?:(?!<|>).)*>((?:(?!<p|<\/p>).|\s)*)<\/p>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}